Select Page

IPv6 Basics

IPv6 | Basic Lab

  • The issue with static routes is that many routes change configurations — and the patch from one router to another often changes as a network grows. You can have thousands of different routes, and if one changes, you could be left manually configuring several routers. This can be a time-consuming process, especially when it comes to larger networks.

Route redistribution is a process that allows a network to use a routing protocol to dynamically route traffic based on information learned from a different routing protocol. Route redistribution helps increase accessibility within networks.

Juniper vMX 14 & EVE-NG Pro is used for this lab.

 Devices Configuration: 

[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R1
set system root-authentication encrypted-password "$1$WaL4BSs9$mlznqm3jQMhdGgufqq1YF1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.1/24
set interfaces lo0 unit 1 family inet address 1.1.1.1/24
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols ospf area 0.0.0.0 interface lo0.1
 
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R2
set system root-authentication encrypted-password "$1$WaL4BSs9$mlznqm3jQMhdGgufqq1YF1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.2/24
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.2/24
set protocols ospf export adv-ospf
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols rip group R2-R3 export R2-R3
set protocols rip group R2-R3 neighbor ge-0/0/1.0
set policy-options policy-statement R2-R3 term t1 from protocol direct
set policy-options policy-statement R2-R3 term t1 from protocol rip
set policy-options policy-statement R2-R3 term t1 from protocol ospf
set policy-options policy-statement R2-R3 term t1 then accept
set policy-options policy-statement adv-ospf term t1 from protocol direct
set policy-options policy-statement adv-ospf term t1 from protocol rip
set policy-options policy-statement adv-ospf term t1 then accept
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R3
set system root-authentication encrypted-password "$1$WaL4BSs9$mlznqm3jQMhdGgufqq1YF1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.3/24
set interfaces lo0 unit 3 family inet address 3.3.3.3/24
set protocols rip group R3-R2 export R3-loop
set protocols rip group R3-R2 neighbor ge-0/0/1.0
set policy-options policy-statement R3-loop term t1 from protocol direct
set policy-options policy-statement R3-loop term t1 from protocol rip
set policy-options policy-statement R3-loop term t1 then accept
— Configuration | Verification —

— Red Config & Verification:

R1>
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols ospf area 0.0.0.0 interface lo0.1

R2>
set protocols ospf export adv-ospf
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols rip group R2-R3 export R2-R3
set protocols rip group R2-R3 neighbor ge-0/0/1.0
set policy-options policy-statement R2-R3 term t1 from protocol direct
set policy-options policy-statement R2-R3 term t1 from protocol rip
set policy-options policy-statement R2-R3 term t1 from protocol ospf
set policy-options policy-statement R2-R3 term t1 then accept
set policy-options policy-statement adv-ospf term t1 from protocol direct
set policy-options policy-statement adv-ospf term t1 from protocol rip
set policy-options policy-statement adv-ospf term t1 then accept

R3>
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.3/24
set interfaces lo0 unit 3 family inet address 3.3.3.3/24
set protocols rip group R3-R2 export R3-loop
set protocols rip group R3-R2 neighbor ge-0/0/1.0
set policy-options policy-statement R3-loop term t1 from protocol direct
set policy-options policy-statement R3-loop term t1 from protocol rip
set policy-options policy-statement R3-loop term t1 then accept
 
[email protected]> show route 

inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/24         *[Direct/0] 00:02:33
                    > via lo0.1
1.1.1.1/32         *[Local/0] 00:02:33
                      Local via lo0.1
3.3.3.0/24         *[OSPF/150] 00:00:30, metric 2, tag 0
                    > to 12.12.12.2 via ge-0/0/0.0
12.12.12.0/24      *[Direct/0] 00:01:29
                    > via ge-0/0/0.0
12.12.12.1/32      *[Local/0] 00:01:30
                      Local via ge-0/0/0.0
23.23.23.0/24      *[OSPF/150] 00:00:30, metric 0, tag 0
                    > to 12.12.12.2 via ge-0/0/0.0
224.0.0.5/32       *[OSPF/10] 00:02:33, metric 1
                      MultiRecv

[email protected]> ping 3.3.3.3 
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=63 time=3.246 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=63 time=3.566 ms
64 bytes from 3.3.3.3: icmp_seq=2 ttl=63 time=2.526 ms
^C
--- 3.3.3.3 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.526/3.113/3.566/0.435 ms
----
[email protected]> show route 

inet.0: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/24         *[OSPF/10] 00:00:30, metric 1
                    > to 12.12.12.1 via ge-0/0/0.0
1.1.1.1/32         *[OSPF/10] 00:00:30, metric 1
                    > to 12.12.12.1 via ge-0/0/0.0
3.3.3.0/24         *[RIP/100] 00:01:19, metric 2, tag 0
                    > to 23.23.23.3 via ge-0/0/1.0
12.12.12.0/24      *[Direct/0] 00:01:20
                    > via ge-0/0/0.0
12.12.12.2/32      *[Local/0] 00:01:31
                      Local via ge-0/0/0.0
23.23.23.0/24      *[Direct/0] 00:01:20
                    > via ge-0/0/1.0
23.23.23.2/32      *[Local/0] 00:01:31
                      Local via ge-0/0/1.0
224.0.0.5/32       *[OSPF/10] 00:02:35, metric 1
                      MultiRecv
224.0.0.9/32       *[RIP/100] 00:02:35, metric 1
                      MultiRecv

----
[email protected]> show route 

inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/24         *[RIP/100] 00:00:26, metric 2, tag 0
                    > to 23.23.23.2 via ge-0/0/1.0
1.1.1.1/32         *[RIP/100] 00:00:26, metric 2, tag 0
                    > to 23.23.23.2 via ge-0/0/1.0
3.3.3.0/24         *[Direct/0] 00:02:34
                    > via lo0.3
3.3.3.3/32         *[Local/0] 00:02:34
                      Local via lo0.3
12.12.12.0/24      *[RIP/100] 00:01:19, metric 2, tag 0
                    > to 23.23.23.2 via ge-0/0/1.0
23.23.23.0/24      *[Direct/0] 00:01:28
                    > via ge-0/0/1.0
23.23.23.3/32      *[Local/0] 00:01:29
                      Local via ge-0/0/1.0
224.0.0.9/32       *[RIP/100] 00:02:34, metric 1
                      MultiRecv

[email protected]> ping 1.1.1.1 source 23.23.23.3 rapid count 10 
PING 1.1.1.1 (1.1.1.1): 56 data bytes
!!!!!!!!!!
--- 1.1.1.1 ping statistics ---
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.179/3.316/11.567/2.764 ms

[email protected]> ping 1.1.1.1 
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=63 time=4.449 ms
64 bytes from 1.1.1.1: icmp_seq=1 ttl=63 time=3.381 ms
64 bytes from 1.1.1.1: icmp_seq=2 ttl=63 time=2.836 ms
^C
--- 1.1.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.836/3.555/4.449/0.670 ms

----
Share on print
Print
Share on google
Google+
Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

Prepaid Phones, SIM Cards, No-Contract & Pay As You Go Phones at a price you wouldn’t expect.

 

The Juniper All-Access | Reading List

Leave a reply

Your email address will not be published. Required fields are marked *

ADENTECH guides

We love to help.

Get our newsletter, join the community: