Select Page

IPv6 Over IPv4

IPv6-over-IPv4 Tunnel

  • This example shows how to configure a unidirectional generic routing encapsulation (GRE) tunnel to transport IPv6 unicast transit traffic across an IPv4 transport network. To provide network connectivity to the two disjoint IPv6 networks.

You can configure the IPv6 tunneling for MPLS to tunnel IPv6 traffic over an MPLS-based IPv4 network. This configuration allows you to interconnect a number of smaller IPv6 networks over an IPv4-based network core, giving you the ability to provide IPv6 service without having to upgrade the switches in your core network. BGP is configured to exchange routes between the IPv6 networks, and data is tunneled between these IPv6 networks by means of IPv4-based MPLS.

Juniper vMX 14 & EVE-NG Pro is used for this lab.

 Devices Configuration: 

[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R1
set system root-authentication encrypted-password "$1$WaL4BSs9$mlznqm3jQMhdGgufqq1YF1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set chassis fpc 0 pic 0 tunnel-services bandwidth 10g
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.1/24
set interfaces gr-0/0/0 unit 13 tunnel source 12.12.12.1
set interfaces gr-0/0/0 unit 13 tunnel destination 23.23.23.3
set interfaces gr-0/0/0 unit 13 family inet
set interfaces gr-0/0/0 unit 13 family inet6 address 2001:13:13:13::1/64
set interfaces gr-0/0/0 unit 13 family inet6 address fe80::1/64
set interfaces lo0 unit 1 family inet6 address 2001:3:3:3::1/64
set routing-options router-id 1.1.1.1
set routing-options autonomous-system 100
set protocols bgp group IBGP type external
set protocols bgp group IBGP peer-as 200
set protocols bgp group IBGP neighbor 12.12.12.2
set protocols ospf3 area 0.0.0.0 interface gr-0/0/0.13
set protocols ospf3 area 0.0.0.0 interface lo0.1
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R2
set system root-authentication encrypted-password "$1$WaL4BSs9$mlznqm3jQMhdGgufqq1YF1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.2/24
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.2/24
set routing-options autonomous-system 200
set protocols bgp group EBGP type external
set protocols bgp group EBGP export direct
set protocols bgp group EBGP peer-as 100
set protocols bgp group EBGP neighbor 12.12.12.1
set protocols bgp group EBGP neighbor 23.23.23.3
set policy-options policy-statement direct term t1 from protocol direct
set policy-options policy-statement direct term t1 then accept
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R3
set system root-authentication encrypted-password "$1$WaL4BSs9$mlznqm3jQMhdGgufqq1YF1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set chassis fpc 0 pic 0 tunnel-services bandwidth 10g
set interfaces gr-0/0/0 unit 13 tunnel source 23.23.23.3
set interfaces gr-0/0/0 unit 13 tunnel destination 12.12.12.1
set interfaces gr-0/0/0 unit 13 family inet
set interfaces gr-0/0/0 unit 13 family inet6 address 2001:13:13:13::3/64
set interfaces gr-0/0/0 unit 13 family inet6 address fe80::3/64
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.3/24
set interfaces lo0 unit 3 family inet6 address 2001:3:3:3::3/64
set routing-options router-id 3.3.3.3
set routing-options autonomous-system 100
set protocols bgp group IBGP type external
set protocols bgp group IBGP peer-as 200
set protocols bgp group IBGP neighbor 23.23.23.2
set protocols ospf3 area 0.0.0.0 interface gr-0/0/0.13
set protocols ospf3 area 0.0.0.0 interface lo0.3
— Configuration | Verification —

— Peering:

R1>
set chassis fpc 0 pic 0 tunnel-services bandwidth 10g
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.1/24
set interfaces gr-0/0/0 unit 13 tunnel source 12.12.12.1
set interfaces gr-0/0/0 unit 13 tunnel destination 23.23.23.3
set interfaces gr-0/0/0 unit 13 family inet
set interfaces gr-0/0/0 unit 13 family inet6 address 2001:13:13:13::1/64
set interfaces gr-0/0/0 unit 13 family inet6 address fe80::1/64
set interfaces lo0 unit 1 family inet6 address 2001:3:3:3::1/64
set routing-options router-id 1.1.1.1
set routing-options autonomous-system 100
set protocols bgp group IBGP type external
set protocols bgp group IBGP peer-as 200
set protocols bgp group IBGP neighbor 12.12.12.2
set protocols ospf3 area 0.0.0.0 interface gr-0/0/0.13
set protocols ospf3 area 0.0.0.0 interface lo0.1

R2>
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.2/24
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.2/24
set routing-options autonomous-system 200
set protocols bgp group EBGP type external
set protocols bgp group EBGP export direct
set protocols bgp group EBGP peer-as 100
set protocols bgp group EBGP neighbor 12.12.12.1
set protocols bgp group EBGP neighbor 23.23.23.3
set policy-options policy-statement direct term t1 from protocol direct
set policy-options policy-statement direct term t1 then accept

R3>
set chassis fpc 0 pic 0 tunnel-services bandwidth 10g
set interfaces gr-0/0/0 unit 13 tunnel source 23.23.23.3
set interfaces gr-0/0/0 unit 13 tunnel destination 12.12.12.1
set interfaces gr-0/0/0 unit 13 family inet
set interfaces gr-0/0/0 unit 13 family inet6 address 2001:13:13:13::3/64
set interfaces gr-0/0/0 unit 13 family inet6 address fe80::3/64
set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.3/24
set interfaces lo0 unit 3 family inet6 address 2001:3:3:3::3/64
set routing-options router-id 3.3.3.3
set routing-options autonomous-system 100
set protocols bgp group IBGP type external
set protocols bgp group IBGP peer-as 200
set protocols bgp group IBGP neighbor 23.23.23.2
set protocols ospf3 area 0.0.0.0 interface gr-0/0/0.13
set protocols ospf3 area 0.0.0.0 interface lo0.3
[email protected]> ping 2001:13:13:13::3 source 2001:13:13:13::1 
PING6(56=40+8+8 bytes) 2001:13:13:13::1 --> 2001:13:13:13::3
16 bytes from 2001:13:13:13::3, icmp_seq=0 hlim=64 time=7.282 ms
16 bytes from 2001:13:13:13::3, icmp_seq=1 hlim=64 time=3.273 ms
16 bytes from 2001:13:13:13::3, icmp_seq=2 hlim=64 time=2.955 ms
16 bytes from 2001:13:13:13::3, icmp_seq=3 hlim=64 time=2.751 ms
^C
--- 2001:13:13:13::3 ping6 statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 2.751/4.065/7.282/1.866 ms

[email protected]> show ospf3 neighbor 
ID               Interface              State     Pri   Dead
3.3.3.3          gr-0/0/0.13            Full      128     38
  Neighbor-address fe80::3

[email protected]> show bgp summary 
Groups: 1 Peers: 1 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       2          1          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
12.12.12.2              200         29         30       0       0       12:00 1/2/2/0              0/0/0/0


[email protected]> show route protocol ospf3    

inet.0: 3 destinations, 4 routes (3 active, 0 holddown, 0 hidden)

inet6.0: 9 destinations, 10 routes (9 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2001:3:3:3::3/128  *[OSPF3/10] 00:12:17, metric 1
                    > via gr-0/0/0.13
2001:13:13:13::/64  [OSPF3/10] 00:12:22, metric 1
                    > via gr-0/0/0.13
ff02::5/128        *[OSPF3/10] 00:13:42, metric 1
                      MultiRecv
                      
----
[email protected]> show bgp summary 
Groups: 1 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       0          0          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
12.12.12.1              100         32         32       0       0       13:14 0/0/0/0              0/0/0/0
23.23.23.3              100         32         33       0       0       13:15 0/0/0/0              0/0/0/0

----
[email protected]> ping 2001:13:13:13::1 source 2001:13:13:13::3 
PING6(56=40+8+8 bytes) 2001:13:13:13::3 --> 2001:13:13:13::1
16 bytes from 2001:13:13:13::1, icmp_seq=0 hlim=64 time=5.543 ms
16 bytes from 2001:13:13:13::1, icmp_seq=1 hlim=64 time=2.957 ms
16 bytes from 2001:13:13:13::1, icmp_seq=2 hlim=64 time=3.897 ms
16 bytes from 2001:13:13:13::1, icmp_seq=3 hlim=64 time=3.635 ms
^C
--- 2001:13:13:13::1 ping6 statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 2.957/4.008/5.543/0.950 ms

[email protected]> show ospf3 neighbor 
ID               Interface              State     Pri   Dead
1.1.1.1          gr-0/0/0.13            Full      128     39
  Neighbor-address fe80::1

[email protected]> show bgp summary 
Groups: 1 Peers: 1 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       2          1          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
23.23.23.2              200         28         28       0       0       11:38 1/2/2/0              0/0/0/0

[email protected]> show route protocol ospf3 

inet.0: 3 destinations, 4 routes (3 active, 0 holddown, 0 hidden)

inet6.0: 9 destinations, 10 routes (9 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2001:3:3:3::1/128  *[OSPF3/10] 00:12:34, metric 1
                    > via gr-0/0/0.13
2001:13:13:13::/64  [OSPF3/10] 00:12:39, metric 1
                    > via gr-0/0/0.13
ff02::5/128        *[OSPF3/10] 00:13:57, metric 1
                      MultiRecv 

 

Share on print
Print
Share on google
Google+
Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

Prepaid Phones, SIM Cards, No-Contract & Pay As You Go Phones at a price you wouldn’t expect.

 

The Juniper All-Access | Reading List

Leave a reply

Your email address will not be published. Required fields are marked *

ADENTECH guides

We love to help.

Get our newsletter, join the community: