Select Page

MED AttributE

MED | Multiple Exit Discriminator Route Selection …

  • A non-transitive attribute, manipulate how traffic should enter into AS | (how other ASs enter your AS to reach a certain prefix).

The MED attribute has a value that is referred to as a metric. If all other factors in determining an exit point are equal, the exit point with the lowest metric is preferred.  If a MED is received over an external BGP link, it is propagated over internal links to other BGP-enabled devices within the AS. BGP update messages include a MED metric if the route was learned from BGP and already had a MED metric associated with it, or if you configure the MED metric in the configuration file.  A MED metric is advertised with a route according to the following general rules:

  • A more specific metric overrides a less specific metric. That is, a group-specific metric overrides a global BGP metric, and a peer-specific metric overrides a global BGP or group-specific metric.

  • A metric defined with a routing policy overrides a metric defined with the metric-out statement.

  • If any metric is defined, it overrides a metric received in a route.

  • If the received route does not have an associated MED metric, and if you do not explicitly configure a metric value, no metric is advertised. When you do not explicitly configure a metric value, the MED value is equivalent to zero (0) when advertising an active route.

Juniper vMX 14 & EVE-NG Pro is used for this lab.

 Devices Configuration: 

[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R1
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.1/24
set interfaces ge-0/0/1 unit 0 family inet address 13.13.13.1/24
set interfaces lo0 unit 1 family inet address 1.1.1.1/24
set interfaces lo0 unit 1 family inet address 11.11.11.11/24
set routing-options autonomous-system 100
set protocols bgp group iBGP type internal
set protocols bgp group iBGP traceoptions file R1-log
set protocols bgp group iBGP traceoptions flag all
set protocols bgp group iBGP export R1-loop
set protocols bgp group iBGP cluster 1.1.1.1
set protocols bgp group iBGP peer-as 100
set protocols bgp group iBGP neighbor 12.12.12.2
set protocols bgp group iBGP neighbor 13.13.13.3
set policy-options policy-statement R1-loop term t1 from protocol direct
set policy-options policy-statement R1-loop term t1 then accept
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R2
set system root-authentication encrypted-password "$1$gQQMnrjZ$0y8.izSPbRBPDQ37sp0t70"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.2/24
set interfaces ge-0/0/2 unit 0 family inet address 24.24.24.2/24
set routing-options autonomous-system 100
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 100
set protocols bgp group iBGP neighbor 12.12.12.1
set protocols bgp group eBGP type external
set protocols bgp group eBGP peer-as 200
set protocols bgp group eBGP neighbor 24.24.24.4
set policy-options policy-statement next-hop term t1 then next-hop self
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R3
set system root-authentication encrypted-password "$1$qwaVLOJm$ZyIK8zBMf5lnBErcYT0mz0"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/1 unit 0 family inet address 13.13.13.3/24
set interfaces ge-0/0/3 unit 0 family inet address 35.35.35.3/24
set routing-options autonomous-system 100
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 100
set protocols bgp group iBGP neighbor 13.13.13.1
set protocols bgp group eBGP type external
set protocols bgp group eBGP peer-as 200
set protocols bgp group eBGP neighbor 35.35.35.5
set policy-options policy-statement next-hop term t1 then next-hop self
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R4
set system root-authentication encrypted-password "$1$.PVBvHjK$w5rPIhxtZRpFph6gWcI8M0"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 46.46.46.4/24
set interfaces ge-0/0/2 unit 0 family inet address 24.24.24.4/24
set routing-options autonomous-system 200
set protocols bgp group eBGP type external
set protocols bgp group eBGP export MED
set protocols bgp group eBGP peer-as 100
set protocols bgp group eBGP neighbor 24.24.24.2
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 200
set protocols bgp group iBGP neighbor 46.46.46.6
set policy-options policy-statement MED term t1 from route-filter 66.66.66.0/24 exact
set policy-options policy-statement MED term t1 then metric 5000
set policy-options policy-statement MED term t2 from route-filter 6.6.6.0/24 exact
set policy-options policy-statement MED term t2 then metric 250
set policy-options policy-statement next-hop term t1 then next-hop self
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R5
set system root-authentication encrypted-password "$1$k7n8w/wo$8euhVYmjwdLXi0ony6IbP/"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/1 unit 0 family inet address 56.56.56.5/24
set interfaces ge-0/0/3 unit 0 family inet address 35.35.35.5/24
set routing-options autonomous-system 200
set protocols bgp group eBGP type external
set protocols bgp group eBGP export MED
set protocols bgp group eBGP peer-as 100
set protocols bgp group eBGP neighbor 35.35.35.3
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 200
set protocols bgp group iBGP neighbor 56.56.56.6
set policy-options policy-statement MED term t1 from route-filter 66.66.66.0/24 exact
set policy-options policy-statement MED term t1 from route-filter 6.6.6.0/24 exact
set policy-options policy-statement MED term t1 then metric 500
set policy-options policy-statement next-hop term t1 then next-hop self
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R6
set system root-authentication encrypted-password "$1$kHQdSe5p$nauLFLu5lENsFFOz2rgTd."
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 46.46.46.6/24
set interfaces ge-0/0/1 unit 0 family inet address 56.56.56.6/24
set interfaces lo0 unit 6 family inet address 6.6.6.6/24
set interfaces lo0 unit 6 family inet address 66.66.66.66/24
set routing-options autonomous-system 200
set protocols bgp group iBGP type internal
set protocols bgp group iBGP traceoptions file R6-logs
set protocols bgp group iBGP traceoptions flag all
set protocols bgp group iBGP export R6-loop
set protocols bgp group iBGP cluster 6.6.6.6
set protocols bgp group iBGP peer-as 200
set protocols bgp group iBGP neighbor 46.46.46.4
set protocols bgp group iBGP neighbor 56.56.56.5
set policy-options policy-statement R6-loop term t1 from interface lo0.6
set policy-options policy-statement R6-loop term t1 then accept
— Configuration | Verification —

— iBGP & eBGP Peering:

R1>
set routing-options autonomous-system 100
set protocols bgp group iBGP type internal
set protocols bgp group iBGP traceoptions file R1-log
set protocols bgp group iBGP traceoptions flag all
set protocols bgp group iBGP export R1-loop
set protocols bgp group iBGP cluster 1.1.1.1
set protocols bgp group iBGP peer-as 100
set protocols bgp group iBGP neighbor 12.12.12.2
set protocols bgp group iBGP neighbor 13.13.13.3
set policy-options policy-statement R1-loop term t1 from protocol direct
set policy-options policy-statement R1-loop term t1 then accept

R2
>
set routing-options autonomous-system 100
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 100
set protocols bgp group iBGP neighbor 12.12.12.1
set protocols bgp group eBGP type external
set protocols bgp group eBGP peer-as 200
set protocols bgp group eBGP neighbor 24.24.24.4
set policy-options policy-statement next-hop term t1 then next-hop self

R3>
set routing-options autonomous-system 100
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 100
set protocols bgp group iBGP neighbor 13.13.13.1
set protocols bgp group eBGP type external
set protocols bgp group eBGP peer-as 200
set protocols bgp group eBGP neighbor 35.35.35.5
set policy-options policy-statement next-hop term t1 then next-hop self

R4>
set routing-options autonomous-system 200
set protocols bgp group eBGP type external
set protocols bgp group eBGP peer-as 100
set protocols bgp group eBGP neighbor 24.24.24.2
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 200
set protocols bgp group iBGP neighbor 46.46.46.6
set policy-options policy-statement next-hop term t1 then next-hop self

R5>
set routing-options autonomous-system 200
set protocols bgp group eBGP type external
set protocols bgp group eBGP peer-as 100
set protocols bgp group eBGP neighbor 35.35.35.3
set protocols bgp group iBGP type internal
set protocols bgp group iBGP export next-hop
set protocols bgp group iBGP peer-as 200
set protocols bgp group iBGP neighbor 56.56.56.6
set policy-options policy-statement next-hop term t1 then next-hop self

R6>
set routing-options autonomous-system 200
set protocols bgp group iBGP type internal
set protocols bgp group iBGP traceoptions file R6-logs
set protocols bgp group iBGP traceoptions flag all
set protocols bgp group iBGP export R6-loop
set protocols bgp group iBGP cluster 6.6.6.6
set protocols bgp group iBGP peer-as 200
set protocols bgp group iBGP neighbor 46.46.46.4
set protocols bgp group iBGP neighbor 56.56.56.5
set policy-options policy-statement R6-loop term t1 from interface lo0.6
set policy-options policy-statement R6-loop term t1 then accept
[email protected]> show bgp summary 
Groups: 1 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       4          2          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
12.12.12.2              100         25         30       0       0       11:18 2/2/2/0              0/0/0/0
13.13.13.3              100         28         30       0       0       11:26 0/2/2/0              0/0/0/0
               
[email protected]> show bgp summary 
Groups: 2 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       6          5          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
12.12.12.1              100         29         25       0       0       10:07 3/4/4/0              0/0/0/0
24.24.24.4              200         30         26       0       0       10:07 2/2/2/0              0/0/0/0


[email protected]> show bgp summary Groups: 2 Peers: 2 Down peers: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet.0 8 5 0 0 0 0 Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped... 13.13.13.1 100 29 28 0 0 10:57 3/6/6/0 0/0/0/0 35.35.35.5 200 25 28 0 0 10:57 2/2/2/0 0/0/0/0
[email protected]> show bgp summary 
Groups: 2 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       6          5          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
24.24.24.2              100         25         30       0       0       12:07 3/3/3/0              0/0/0/0
46.46.46.6              200         27         31       0       0       12:14 2/3/3/0              0/0/0/0

[email protected]> show bgp summary 
Groups: 2 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       8          5          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
35.35.35.3              100         28         26       0       0       10:14 3/3/3/0              0/0/0/0
56.56.56.6              200         28         26       0       0       10:13 2/5/5/0              0/0/0/0
 [email protected]> show bgp summary 
Groups: 1 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                       6          4          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
46.46.46.4              200         30         27       0       0       10:13 3/3/3/0              0/0/0/0
56.56.56.5              200         26         29       0       0       10:13 1/3/3/0              0/0/0/0

— Default Route/path from R1–>R6 (Without MED) 

R1 reach R6 via R2-R4 (based on below output). 
/** Why R1 prefer R2-R4 path to reach R6? Let's verify;
[email protected]> show route 6.6.6.6             

inet.0: 10 destinations, 12 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

6.6.6.0/24         *[BGP/170] 00:08:04, localpref 100
                      AS path: 200 I, validation-state: unverified
                    > to 12.12.12.2 via ge-0/0/0.0
                    [BGP/170] 00:08:50, localpref 100
                      AS path: 200 I, validation-state: unverified
                    > to 13.13.13.3 via ge-0/0/1.0

[email protected]> ping 6.6.6.6 source 1.1.1.1    
PING 6.6.6.6 (6.6.6.6): 56 data bytes
64 bytes from 6.6.6.6: icmp_seq=0 ttl=62 time=2.898 ms
64 bytes from 6.6.6.6: icmp_seq=1 ttl=62 time=2.456 ms
^C
--- 6.6.6.6 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.456/2.677/2.898/0.221 ms

[email protected]> trace 6.6.6.6 source 1.1.1.1   
traceroute to 6.6.6.6 (6.6.6.6) from 1.1.1.1, 30 hops max, 40 byte packets
 1  12.12.12.2 (12.12.12.2)  3.574 ms  0.790 ms  0.747 ms
 2  24.24.24.4 (24.24.24.4)  4.790 ms  1.298 ms  1.278 ms
 3  6.6.6.6 (6.6.6.6)  3.922 ms  2.126 ms  1.947 ms

[email protected]> show route 1.1.1.1 

inet.0: 10 destinations, 12 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/24         *[BGP/170] 00:10:22, localpref 100
                      AS path: 100 I, validation-state: unverified
                    > to 46.46.46.4 via ge-0/0/0.0
                    [BGP/170] 00:11:14, localpref 100
                      AS path: 100 I, validation-state: unverified
                    > to 56.56.56.5 via ge-0/0/1.0

[email protected]> ping 1.1.1.1 source 6.6.6.6 
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=62 time=3.057 ms
64 bytes from 1.1.1.1: icmp_seq=1 ttl=62 time=3.053 ms
^C
--- 1.1.1.1 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 3.053/3.055/3.057/0.002 ms

[email protected]> trace 1.1.1.1 source 6.6.6.6   
traceroute to 1.1.1.1 (1.1.1.1) from 6.6.6.6, 30 hops max, 40 byte packets
 1  46.46.46.4 (46.46.46.4)  1.382 ms  0.837 ms  0.766 ms
 2  24.24.24.2 (24.24.24.2)  3.289 ms  1.174 ms  1.099 ms
 3  1.1.1.1 (1.1.1.1)  4.431 ms  1.856 ms  1.871 ms

[email protected]> show route 6.6.6.6 extensive inet.0: 10 destinations, 12 routes (10 active, 0 holddown, 0 hidden) 6.6.6.0/24 (2 entries, 1 announced) TSI: KRT in-kernel 6.6.6.0/24 -> {indirect(1048575)} Page 0 idx 0, (group iBGP type Internal) Type 1 val 0x959a54c (adv_entry) Advertised metrics: Nexthop: 12.12.12.2 Localpref: 100 AS path: [100] 200 I Communities: Cluster ID: 1.1.1.1 Originator ID: 12.12.12.2 Advertise: 00000002 Path 6.6.6.0 from 12.12.12.2 Vector len 4. Val: 0 *BGP Preference: 170/-101 Next hop type: Indirect Address: 0x968c64c Next-hop reference count: 6 Source: 12.12.12.2 Next hop type: Router, Next hop index: 564 Next hop: 12.12.12.2 via ge-0/0/0.0, selected Session Id: 0x142 Protocol next hop: 12.12.12.2 Indirect next hop: 0x9648220 1048575 INH Session ID: 0x143 State: <Active Int Ext> Local AS: 100 Peer AS: 100 Age: 13:43 Metric2: 0 Validation State: unverified Task: BGP_100.12.12.12.2+56259 Announcement bits (3): 0-KRT 1-BGP_RT_Background 2-Resolve tree 1 AS path: 200 I Accepted Localpref: 100 Router ID: 12.12.12.2 Indirect next hops: 1 Protocol next hop: 12.12.12.2 Indirect next hop: 0x9648220 1048575 INH Session ID: 0x143 Indirect path forwarding next hops: 1 Next hop type: Router Next hop: 12.12.12.2 via ge-0/0/0.0 Session Id: 0x142 12.12.12.0/24 Originating RIB: inet.0 Node path count: 1 Forwarding nexthops: 1 Next hop type: Interface Nexthop: via ge-0/0/0.0 BGP Preference: 170/-101 Next hop type: Indirect Address: 0x968c4d0 Next-hop reference count: 2 Source: 13.13.13.3 Next hop type: Router, Next hop index: 565 Next hop: 13.13.13.3 via ge-0/0/1.0, selected Session Id: 0x140 Protocol next hop: 13.13.13.3 Indirect next hop: 0x9648110 1048574 INH Session ID: 0x141 State: <NotBest Int Ext> Inactive reason: Not Best in its group - Router ID Local AS: 100 Peer AS: 100 Age: 14:29 Metric2: 0 Validation State: unverified Task: BGP_100.13.13.13.3+60514 AS path: 200 I Accepted Localpref: 100 Router ID: 13.13.13.3 Indirect next hops: 1 Protocol next hop: 13.13.13.3 Indirect next hop: 0x9648110 1048574 INH Session ID: 0x141 Indirect path forwarding next hops: 1 Next hop type: Router Next hop: 13.13.13.3 via ge-0/0/1.0 Session Id: 0x140 13.13.13.0/24 Originating RIB: inet.0 Node path count: 1 Forwarding nexthops: 1 Next hop type: Interface Nexthop: via ge-0/0/1.0

/** Due to Router-ID ., path from R1 to R6 via R2-R4 is selected.

— Modify MED value on R5 to see if route/path changes?:

>> MED CONFIG:  [email protected]# 
set policy-options policy-statement MED term t1 from route-filter 66.66.66.0/24 exact
set policy-options policy-statement MED term t1 from route-filter 6.6.6.0/24 exact
set policy-options policy-statement MED term t1 then metric 500
set protocols bgp group eBGP export MED
[email protected]> show route advertising-protocol bgp 35.35.35.3 

inet.0: 10 destinations, 12 routes (9 active, 0 holddown, 3 hidden)
  Prefix                  Nexthop              MED     Lclpref    AS path
* 6.6.6.0/24              Self                 500                I
* 66.66.66.0/24           Self                 500                I

[email protected]> traceroute 6.6.6.6 source 1.1.1.1 traceroute to 6.6.6.6 (6.6.6.6) from 1.1.1.1, 30 hops max, 40 byte packets 1 12.12.12.2 (12.12.12.2) 1.724 ms 0.936 ms 0.831 ms 2 24.24.24.4 (24.24.24.4) 2.000 ms 1.341 ms 1.205 ms 3 6.6.6.6 (6.6.6.6) 2.426 ms 1.975 ms 1.799 ms
/** Note that R1 is still going through R2 to reach R6. This is because R2 still using the default MED ZERO (0) value.
-- Lets change MED value (higher) on R4 so route should change to R1-->R3 to reach R6.
set policy-options policy-statement MED term t1 from route-filter 66.66.66.0/24 exact
set policy-options policy-statement MED term t1 from route-filter 6.6.6.0/24 exact
set policy-options policy-statement MED term t1 then metric 5000
set protocols bgp group eBGP export MED

[email protected]> show route advertising-protocol bgp 24.24.24.2 inet.0: 10 destinations, 10 routes (9 active, 0 holddown, 1 hidden) Prefix Nexthop MED Lclpref AS path * 6.6.6.0/24 Self 5000 I * 66.66.66.0/24 Self 5000 I [email protected]> show route advertising-protocol bgp 46.46.46.6 inet.0: 10 destinations, 10 routes (9 active, 0 holddown, 1 hidden) Prefix Nexthop MED Lclpref AS path * 1.1.1.0/24 Self 100 100 I * 11.11.11.0/24 Self 100 100 I * 13.13.13.0/24 Self 100 100 I
[email protected]> traceroute 6.6.6.6 source 1.1.1.1 traceroute to 6.6.6.6 (6.6.6.6) from 1.1.1.1, 30 hops max, 40 byte packets 1 13.13.13.3 (13.13.13.3) 9.909 ms 0.924 ms 0.820 ms 2 35.35.35.5 (35.35.35.5) 10.678 ms 1.523 ms 1.420 ms 3 6.6.6.6 (6.6.6.6) 2.929 ms 2.271 ms 2.064 ms
/** Note that path has changed from R2 to R3 for traffic initiated from R1 destined to R6.

— Addition Theory: LOAD-BALANCING

>> R1 to use path via R2 to reach R6 network 6.6.6.0/24. ... AND: R1 continue to use path via R3 for 66.66.66.0/24
[email protected]R4# 
set policy-options policy-statement MED term t1 from route-filter 66.66.66.0/24 exact
set policy-options policy-statement MED term t1 then metric 5000
set policy-options policy-statement MED term t2 from route-filter 6.6.6.0/24 exact
set policy-options policy-statement MED term t2 then metric 250
set protocols bgp group eBGP export MED 
[email protected]> show route advertising-protocol bgp 24.24.24.2 

inet.0: 10 destinations, 10 routes (9 active, 0 holddown, 1 hidden)
  Prefix                  Nexthop              MED     Lclpref    AS path
* 6.6.6.0/24              Self                 250                I
* 66.66.66.0/24           Self                 5000               I

[email protected]> show route advertising-protocol bgp 46.46.46.6    

inet.0: 10 destinations, 10 routes (9 active, 0 holddown, 1 hidden)
  Prefix                  Nexthop              MED     Lclpref    AS path
* 1.1.1.0/24              Self                         100        100 I
* 11.11.11.0/24           Self                         100        100 I
* 13.13.13.0/24           Self                         100        100 I

[email protected]> traceroute 6.6.6.6 source 1.1.1.1 traceroute to 6.6.6.6 (6.6.6.6) from 1.1.1.1, 30 hops max, 40 byte packets 1 12.12.12.2 (12.12.12.2) 1.411 ms 0.821 ms 0.765 ms 2 24.24.24.4 (24.24.24.4) 1.603 ms 1.289 ms 1.271 ms 3 6.6.6.6 (6.6.6.6) 2.335 ms 1.913 ms 2.129 ms [email protected]> traceroute 66.66.66.66 source 1.1.1.1 traceroute to 66.66.66.66 (66.66.66.66) from 1.1.1.1, 30 hops max, 40 byte packets 1 13.13.13.3 (13.13.13.3) 1.497 ms 0.915 ms 0.886 ms 2 35.35.35.5 (35.35.35.5) 1.787 ms 1.607 ms 1.674 ms 3 66.66.66.66 (66.66.66.66) 2.659 ms 2.019 ms 1.838 ms
/** R1 now using both links to reach R6.

— Addition Theory: FAILOVER TESTING

>> Shutdown link b/w R1 & R2 and check path via R1-> R3 still available for all traffic.
[email protected]R4# 
set policy-options policy-statement MED term t1 from route-filter 66.66.66.0/24 exact
set policy-options policy-statement MED term t1 then metric 5000
set policy-options policy-statement MED term t2 from route-filter 6.6.6.0/24 exact
set policy-options policy-statement MED term t2 then metric 250
set protocols bgp group eBGP export MED 
[email protected]> ping 6.6.6.6 source 1.1.1.1 
PING 6.6.6.6 (6.6.6.6): 56 data bytes
64 bytes from 6.6.6.6: icmp_seq=0 ttl=62 time=5.306 ms
64 bytes from 6.6.6.6: icmp_seq=1 ttl=62 time=3.018 ms
^C
--- 6.6.6.6 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 3.018/4.162/5.306/1.144 ms

[email protected]> ping 66.66.66.66 source 1.1.1.1 
PING 66.66.66.66 (66.66.66.66): 56 data bytes
64 bytes from 66.66.66.66: icmp_seq=0 ttl=62 time=2.628 ms
64 bytes from 66.66.66.66: icmp_seq=1 ttl=62 time=2.302 ms
^C
--- 66.66.66.66 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.302/2.465/2.628/0.163 ms

[email protected]> trace 6.6.6.6 source 1.1.1.1       
traceroute to 6.6.6.6 (6.6.6.6) from 1.1.1.1, 30 hops max, 40 byte packets
 1  13.13.13.3 (13.13.13.3)  1.569 ms  0.892 ms  0.820 ms
 2  35.35.35.5 (35.35.35.5)  1.631 ms  1.822 ms  1.174 ms
 3  6.6.6.6 (6.6.6.6)  2.314 ms  1.890 ms  1.930 ms

[email protected]> trace 66.66.66.66 source 1.1.1.1 
traceroute to 66.66.66.66 (66.66.66.66) from 1.1.1.1, 30 hops max, 40 byte packets
 1  13.13.13.3 (13.13.13.3)  1.257 ms  1.109 ms  0.631 ms
 2  35.35.35.5 (35.35.35.5)  1.559 ms  2.727 ms  1.192 ms
 3  66.66.66.66 (66.66.66.66)  78.977 ms  2.034 ms  1.877 ms

[email protected]> show route hidden inet.0: 8 destinations, 8 routes (6 active, 0 holddown, 2 hidden) + = Active Route, - = Last Active, * = Both 1.1.1.0/24 [BGP/170] 00:02:53, localpref 100, from 46.46.46.6 AS path: 100 I, validation-state: unverified Unusable 11.11.11.0/24 [BGP/170] 00:02:53, localpref 100, from 46.46.46.6 AS path: 100 I, validation-state: unverified Unusable
Share on print
Print
Share on google
Google+
Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

Prepaid Phones, SIM Cards, No-Contract & Pay As You Go Phones at a price you wouldn’t expect.

 

The Juniper All-Access | Reading List

Leave a reply

Your email address will not be published. Required fields are marked *

ADENTECH guides

We love to help.

Get our newsletter, join the community: