Select Page

OSPF AreaS

OSPF | Multi-Area OSPF & Router Types

  • The use of multiple areas will generally improve protocol scalability, as most link-state advertisement (LSA) types are not flooded across area boundaries.

By default, a single interface can belong to only one OSPF area. However, in some situations, you might want to configure an interface to belong to more than one area. Doing so allows the corresponding link to be considered an intra-area link in multiple areas and to be preferred over other higher-cost intra-area paths. For example, you can configure an interface to belong to multiple areas with a high-speed backbone link between two area border routers (ABRs) so you can create multiarea adjacencies that belong to different areas.

Juniper vMX 14 & EVE-NG Pro is used for this lab.

 Devices Configuration: 

[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R1
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/1 unit 0 family inet address 12.12.12.1/24
set interfaces ge-0/0/2 unit 0 family inet address 13.13.13.1/24
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0

 
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R2
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 24.24.24.2/24
set interfaces ge-0/0/1 unit 0 family inet address 12.12.12.2/24
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
set protocols ospf area 0.0.0.24 interface ge-0/0/0.0
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R3
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/2 unit 0 family inet address 13.13.13.3/24
set interfaces ge-0/0/3 unit 0 family inet address 35.35.35.3/24
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
set protocols ospf area 0.0.0.35 interface ge-0/0/3.0
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R4
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 24.24.24.4/24
set interfaces lo0 unit 4 family inet address 10.0.0.4/24
set interfaces lo0 unit 4 family inet address 10.0.1.4/24
set interfaces lo0 unit 4 family inet address 10.0.2.4/24
set interfaces lo0 unit 4 family inet address 10.0.3.4/24
set protocols ospf area 0.0.0.24 interface ge-0/0/0.0
set protocols ospf area 0.0.0.24 interface lo0.4
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R5
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 56.56.56.5/24
set interfaces ge-0/0/3 unit 0 family inet address 35.35.35.5/24
set protocols ospf area 0.0.0.35 interface ge-0/0/3.0
[email protected]> show configuration | display set 
set version 14.1R4.8
set system host-name R6
set system root-authentication encrypted-password "$1$tO/JJjsr$6UERRBvamum8jyb8WbD5p1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 56.56.56.6/24
set interfaces lo0 unit 6 family inet address 192.168.0.6/24
set interfaces lo0 unit 6 family inet address 192.168.1.6/24
set interfaces lo0 unit 6 family inet address 192.168.2.6/24
set interfaces lo0 unit 6 family inet address 192.168.3.6/24
set routing-options static route 0.0.0.0/0 next-hop 56.56.56.5
— Configuration | Verification —

— OSPF Neighbor:

R1>
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
R2>
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
set protocols ospf area 0.0.0.24 interface ge-0/0/0.0

R3>
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
set protocols ospf area 0.0.0.35 interface ge-0/0/3.0
R4>
set protocols ospf area 0.0.0.24 interface ge-0/0/0.0
set protocols ospf area 0.0.0.24 interface lo0.4
R5>
set protocols ospf area 0.0.0.35 interface ge-0/0/3.0
[email protected]> show ospf neighbor                 
Address          Interface              State     ID               Pri  Dead
12.12.12.2       ge-0/0/1.0             Full      12.12.12.2       128    32
13.13.13.3       ge-0/0/2.0             Full      13.13.13.3       128    33
 [email protected]> show ospf neighbor                 
Address          Interface              State     ID               Pri  Dead
12.12.12.1       ge-0/0/1.0             Full      12.12.12.1       128    32
24.24.24.4       ge-0/0/0.0             Full      10.0.0.4         128    39
 [email protected]> show ospf neighbor 
Address          Interface              State     ID               Pri  Dead
13.13.13.1       ge-0/0/2.0             Full      12.12.12.1       128    33
35.35.35.5       ge-0/0/3.0             Full      35.35.35.5       128    38
[email protected]> show ospf neighbor                 
Address          Interface              State     ID               Pri  Dead
24.24.24.2       ge-0/0/0.0             Full      12.12.12.2       128    35
[email protected]> show ospf neighbor                 
Address          Interface              State     ID               Pri  Dead
35.35.35.3       ge-0/0/3.0             Full      13.13.13.3       128    38
[email protected]> show ospf neighbor extensive 
Address          Interface              State     ID               Pri  Dead
12.12.12.1       ge-0/0/1.0             Full      12.12.12.1       128    35
  Area 0.0.0.0, opt 0x52, DR 12.12.12.2, BDR 12.12.12.1
  Up 00:26:42, adjacent 00:26:01
   Topology default (ID 0) -> Bidirectional
24.24.24.4       ge-0/0/0.0             Full      10.0.0.4         128    38
  Area 0.0.0.24, opt 0x52, DR 24.24.24.2, BDR 24.24.24.4
  Up 00:26:43, adjacent 00:26:10
   Topology default (ID 0) -> Bidirectional
[email protected]> show ospf neighbor detail 
Address          Interface              State     ID               Pri  Dead
13.13.13.1       ge-0/0/2.0             Full      12.12.12.1       128    39
  Area 0.0.0.0, opt 0x52, DR 13.13.13.3, BDR 13.13.13.1
  Up 00:26:04, adjacent 00:25:15
35.35.35.5       ge-0/0/3.0             Full      35.35.35.5       128    39
  Area 0.0.0.35, opt 0x52, DR 35.35.35.5, BDR 35.35.35.3
  Up 00:26:05, adjacent 00:25:34

[email protected]> show ospf neighbor extensive 
Address          Interface              State     ID               Pri  Dead
24.24.24.2       ge-0/0/0.0             Full      12.12.12.2       128    36
  Area 0.0.0.24, opt 0x52, DR 24.24.24.2, BDR 24.24.24.4
  Up 00:27:46, adjacent 00:27:13
   Topology default (ID 0) -> Bidirectional

[email protected]> show ospf neighbor extensive 
Address          Interface              State     ID               Pri  Dead
35.35.35.3       ge-0/0/3.0             Full      13.13.13.3       128    32
  Area 0.0.0.35, opt 0x52, DR 35.35.35.5, BDR 35.35.35.3
  Up 00:28:01, adjacent 00:27:31
   Topology default (ID 0) -> Bidirectional

[email protected]> show ospf neighbor extensive Address Interface State ID Pri Dead 12.12.12.2 ge-0/0/1.0 Full 12.12.12.2 128 36 Area 0.0.0.0, opt 0x52, DR 12.12.12.2, BDR 12.12.12.1 Up 00:28:35, adjacent 00:27:54 Topology default (ID 0) -> Bidirectional 13.13.13.3 ge-0/0/2.0 Full 13.13.13.3 128 36 Area 0.0.0.0, opt 0x52, DR 13.13.13.3, BDR 13.13.13.1 Up 00:28:35, adjacent 00:27:47 Topology default (ID 0) -> Bidirectional
 

 

— Route Table & PING TEST & ABR Routers:

- Route Table on R4 & R5 and PING Test.
[email protected]> show route protocol ospf   
inet.0: 14 destinations, 14 routes (14 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
12.12.12.0/24      *[OSPF/10] 00:38:29, metric 2
                    > to 24.24.24.2 via ge-0/0/0.0
13.13.13.0/24      *[OSPF/10] 00:38:15, metric 3
                    > to 24.24.24.2 via ge-0/0/0.0
35.35.35.0/24      *[OSPF/10] 00:38:10, metric 4
                    > to 24.24.24.2 via ge-0/0/0.0
224.0.0.5/32       *[OSPF/10] 00:40:23, metric 1
                      MultiRecv
 [email protected]> show route protocol ospf   
 inet.0: 16 destinations, 16 routes (16 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
10.0.0.0/24        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.0.4/32        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.1.0/24        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.1.4/32        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.2.0/24        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.2.4/32        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.3.0/24        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
10.0.3.4/32        *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
12.12.12.0/24      *[OSPF/10] 00:40:03, metric 3
                    > to 35.35.35.3 via ge-0/0/3.0
13.13.13.0/24      *[OSPF/10] 00:40:19, metric 2
                    > to 35.35.35.3 via ge-0/0/3.0
24.24.24.0/24      *[OSPF/10] 00:40:03, metric 4
                    > to 35.35.35.3 via ge-0/0/3.0
224.0.0.5/32       *[OSPF/10] 00:42:13, metric 1
                      MultiRecv
[email protected]> ping 35.35.35.5 
PING 35.35.35.5 (35.35.35.5): 56 data bytes
64 bytes from 35.35.35.5: icmp_seq=0 ttl=61 time=6.261 ms
64 bytes from 35.35.35.5: icmp_seq=1 ttl=61 time=5.232 ms
[email protected]> ping 10.0.0.4 
PING 10.0.0.4 (10.0.0.4): 56 data bytes
64 bytes from 10.0.0.4: icmp_seq=0 ttl=61 time=27.806 ms
64 bytes from 10.0.0.4: icmp_seq=1 ttl=61 time=5.939 ms

[email protected]> show ospf overview 
Instance: master
  Router ID: 12.12.12.1
  Route table index: 0
  LSA refresh time: 50 minutes
  Area: 0.0.0.0
    Stub type: Not Stub
    Authentication Type: None
    Area border routers: 2, AS boundary routers: 0
    Neighbors
      Up (in full state): 2
  Topology: default (ID 0)
    Prefix export count: 0
    Full SPF runs: 5
    SPF delay: 0.200000 sec, SPF holddown: 5 sec, SPF rapid runs: 3
    Backup SPF: Not Needed

[email protected]> show ospf overview Instance: master Router ID: 12.12.12.2 Route table index: 0 Area border router LSA refresh time: 50 minutes Area: 0.0.0.0 Stub type: Not Stub Authentication Type: None Area border routers: 1, AS boundary routers: 0 Neighbors Up (in full state): 1 Area: 0.0.0.24 Stub type: Not Stub Authentication Type: None Area border routers: 0, AS boundary routers: 0 Neighbors Up (in full state): 1 Topology: default (ID 0) Prefix export count: 0 Full SPF runs: 8 SPF delay: 0.200000 sec, SPF holddown: 5 sec, SPF rapid runs: 3 Backup SPF: Not Needed

[email protected]> show ospf overview Instance: master Router ID: 13.13.13.3 Route table index: 0 Area border router LSA refresh time: 50 minutes Area: 0.0.0.0 Stub type: Not Stub Authentication Type: None Area border routers: 1, AS boundary routers: 0 Neighbors Up (in full state): 1 Area: 0.0.0.35 Stub type: Not Stub Authentication Type: None Area border routers: 0, AS boundary routers: 0 Neighbors Up (in full state): 1 Topology: default (ID 0) Prefix export count: 0 Full SPF runs: 7 SPF delay: 0.200000 sec, SPF holddown: 5 sec, SPF rapid runs: 3 Backup SPF: Not Needed
    /** Number of ABR routers in each Area.

— OSPF DataBasa:

>> LSA Types:
[email protected]> show ospf database 

    OSPF database, Area 0.0.0.0
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len 
Router   12.12.12.1       12.12.12.1       0x80000005   453  0x22 0x7fb7  48
Router  *12.12.12.2       12.12.12.2       0x80000004  1156  0x22 0xf89d  36
Router   13.13.13.3       13.13.13.3       0x80000004  2716  0x22 0x185   36
Network *12.12.12.2       12.12.12.2       0x80000002   979  0x22 0x9f02  32
Network  13.13.13.3       13.13.13.3       0x80000002  2527  0x22 0x7520  32
Summary *10.0.0.0         12.12.12.2       0x80000002  2571  0x22 0xe129  28
Summary *10.0.0.4         12.12.12.2       0x80000002  2394  0x22 0xb94d  28
Summary *10.0.1.0         12.12.12.2       0x80000002  2217  0x22 0xd633  28
Summary *10.0.1.4         12.12.12.2       0x80000002  2041  0x22 0xae57  28
Summary *10.0.2.0         12.12.12.2       0x80000002  1864  0x22 0xcb3d  28
Summary *10.0.2.4         12.12.12.2       0x80000002  1687  0x22 0xa361  28
Summary *10.0.3.0         12.12.12.2       0x80000002  1510  0x22 0xc047  28
Summary *10.0.3.4         12.12.12.2       0x80000002  1333  0x22 0x986b  28
Summary *24.24.24.0       12.12.12.2       0x80000004  2748  0x22 0xfccd  28
Summary  35.35.35.0       13.13.13.3       0x80000005    50  0x22 0x4f55  28

    OSPF database, Area 0.0.0.24
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len 
Router   10.0.0.4         10.0.0.4         0x80000006   469  0x22 0xd4b9 132
Router  *12.12.12.2       12.12.12.2       0x80000005    73  0x22 0xc983  36
Network *24.24.24.2       12.12.12.2       0x80000003   261  0x22 0xd2c0  32
Summary *12.12.12.0       12.12.12.2       0x80000004   803  0x22 0xae40  28
Summary *13.13.13.0       12.12.12.2       0x80000003   626  0x22 0x9655  28
Summary *35.35.35.0       12.12.12.2       0x80000002   449  0x22 0x8722  28


[email protected]> show ospf database OSPF database, Area 0.0.0.0 Type ID Adv Rtr Seq Age Opt Cksum Len Router 12.12.12.1 12.12.12.1 0x80000005 602 0x22 0x7fb7 48 Router 12.12.12.2 12.12.12.2 0x80000004 1307 0x22 0xf89d 36 Router *13.13.13.3 13.13.13.3 0x80000004 2863 0x22 0x185 36 Network 12.12.12.2 12.12.12.2 0x80000002 1130 0x22 0x9f02 32 Network *13.13.13.3 13.13.13.3 0x80000002 2674 0x22 0x7520 32 Summary 10.0.0.0 12.12.12.2 0x80000002 2722 0x22 0xe129 28 Summary 10.0.0.4 12.12.12.2 0x80000002 2545 0x22 0xb94d 28 Summary 10.0.1.0 12.12.12.2 0x80000002 2368 0x22 0xd633 28 Summary 10.0.1.4 12.12.12.2 0x80000002 2192 0x22 0xae57 28 Summary 10.0.2.0 12.12.12.2 0x80000002 2015 0x22 0xcb3d 28 Summary 10.0.2.4 12.12.12.2 0x80000002 1838 0x22 0xa361 28 Summary 10.0.3.0 12.12.12.2 0x80000002 1661 0x22 0xc047 28 Summary 10.0.3.4 12.12.12.2 0x80000002 1484 0x22 0x986b 28 Summary 24.24.24.0 12.12.12.2 0x80000005 37 0x22 0xface 28 Summary *35.35.35.0 13.13.13.3 0x80000005 197 0x22 0x4f55 28 OSPF database, Area 0.0.0.35 Type ID Adv Rtr Seq Age Opt Cksum Len Router *13.13.13.3 13.13.13.3 0x80000005 397 0x22 0x40be 36 Router 35.35.35.5 35.35.35.5 0x80000004 618 0x22 0xe68 36 Network 35.35.35.5 35.35.35.5 0x80000002 623 0x22 0x8e35 32 Summary *10.0.0.0 13.13.13.3 0x80000002 2297 0x22 0xd72d 28 Summary *10.0.0.4 13.13.13.3 0x80000002 2108 0x22 0xaf51 28 Summary *10.0.1.0 13.13.13.3 0x80000002 1919 0x22 0xcc37 28 Summary *10.0.1.4 13.13.13.3 0x80000002 1730 0x22 0xa45b 28 Summary *10.0.2.0 13.13.13.3 0x80000002 1542 0x22 0xc141 28 Summary *10.0.2.4 13.13.13.3 0x80000002 1353 0x22 0x9965 28 Summary *10.0.3.0 13.13.13.3 0x80000002 1164 0x22 0xb64b 28 Summary *10.0.3.4 13.13.13.3 0x80000002 976 0x22 0x8e6f 28 Summary *12.12.12.0 13.13.13.3 0x80000002 787 0x22 0x9e4d 28 Summary *13.13.13.0 13.13.13.3 0x80000004 2485 0x22 0x6c7b 28 Summary *24.24.24.0 13.13.13.3 0x80000002 598 0x22 0xf6cf 28

 

Share on print
Print
Share on google
Google+
Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

The Juniper All-Access | Reading List

Leave a reply

Your email address will not be published. Required fields are marked *

ADENTECH guides

We love to help.

Get our newsletter, join the community: