Select Page

RIP v2 | BasicS

RIPv2 |Basics

  • By default, RIP does not advertise the subnets that are directly connected through the device's interfaces.
  • RIP is an interior gateway protocol (IGP) that routes packets within a single autonomous system (AS). By default, RIP does not advertise the subnets that are directly connected through the device’s interfaces. For traffic to pass through a RIP network, you must create a routing policy to export these routes. Advertising only the direct routes propagates the routes to the immediately adjacent RIP-enabled router only. To propagate all routes through the entire RIP network, you must configure the routing policy to export the routes learned through RIP.

Juniper vMX 14 & EVE-NG Pro is used for this lab.

 Devices Configuration: 

[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R6
set system root-authentication encrypted-password "$1$5KSw27vy$eTKYA2dZLyRAhJ8aYabkG."
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 86.86.86.6/24
set interfaces ge-0/0/1 unit 0 family inet address 96.96.96.6/24
set interfaces lo0 unit 6 family inet address 6.6.6.6/24
set protocols rip group RIP export R1-loop
set protocols rip group RIP neighbor ge-0/0/1.0
set protocols rip group RIP neighbor ge-0/0/0.0 metric-in 10
set policy-options policy-statement R1-loop term t1 from protocol rip
set policy-options policy-statement R1-loop term t1 from protocol direct
set policy-options policy-statement R1-loop term t1 then accept

[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R7
set system root-authentication encrypted-password "$1$0jY4zDWt$nI/Htx9A3IjTW2LMMXQcn0"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 97.97.97.7/24
set interfaces ge-0/0/1 unit 0 family inet address 87.87.87.7/24
set interfaces lo0 unit 7 family inet address 7.7.7.7/24
set protocols rip group RIP export R7-loop
set protocols rip group RIP neighbor ge-0/0/0.0
set protocols rip group RIP neighbor ge-0/0/1.0 metric-in 10
set policy-options policy-statement R7-loop term t1 from protocol rip
set policy-options policy-statement R7-loop term t1 from protocol direct
set policy-options policy-statement R7-loop term t1 then accept
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R8
set system root-authentication encrypted-password "$1$n2wpXiw9$cxtiquLUz5wIDKetRM.4W/"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 86.86.86.8/24
set interfaces ge-0/0/1 unit 0 family inet address 87.87.87.8/24
set protocols rip group RIP export RIP
set protocols rip group RIP neighbor ge-0/0/0.0
set protocols rip group RIP neighbor ge-0/0/1.0
set policy-options policy-statement RIP term t1 from protocol rip
set policy-options policy-statement RIP term t1 from protocol direct
set policy-options policy-statement RIP term t1 then accept
[email protected]> show configuration |display set 
set version 14.1R4.8
set system host-name R9
set system root-authentication encrypted-password "$1$Kwgeek0v$7tCKqioXiMWwNd.WjrBWn0"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family inet address 97.97.97.9/24
set interfaces ge-0/0/1 unit 0 family inet address 96.96.96.9/24
set protocols rip group RIP export RIP
set protocols rip group RIP neighbor ge-0/0/0.0
set protocols rip group RIP neighbor ge-0/0/1.0
set policy-options policy-statement RIP term t1 from protocol rip
set policy-options policy-statement RIP term t1 from protocol direct
set policy-options policy-statement RIP term t1 then accept
— Configuration | Verification —

— RIP Neighbor:

  R6>
  set protocols rip group RIP export R1-loop
  set protocols rip group RIP neighbor ge-0/0/1.0
  set protocols rip group RIP neighbor ge-0/0/0
  set policy-options policy-statement R1-loop term t1 from protocol rip
  set policy-options policy-statement R1-loop term t1 from protocol direct
  set policy-options policy-statement R1-loop term t1 then accept

  R7>
  set protocols rip group RIP export R7-loop
  set protocols rip group RIP neighbor ge-0/0/0.0
  set protocols rip group RIP neighbor ge-0/0/1
  set policy-options policy-statement R7-loop term t1 from protocol rip
  set policy-options policy-statement R7-loop term t1 from protocol direct
  set policy-options policy-statement R7-loop term t1 then accept

  R8>
  set protocols rip group RIP export RIP
  set protocols rip group RIP neighbor ge-0/0/0.0
  set protocols rip group RIP neighbor ge-0/0/1.0
  set policy-options policy-statement RIP term t1 from protocol rip
  set policy-options policy-statement RIP term t1 from protocol direct
  set policy-options policy-statement RIP term t1 then accept

  R9>
  set protocols rip group RIP export RIP
  set protocols rip group RIP neighbor ge-0/0/0.0
  set protocols rip group RIP neighbor ge-0/0/1.0
  set policy-options policy-statement RIP term t1 from protocol rip
  set policy-options policy-statement RIP term t1 from protocol direct
  set policy-options policy-statement RIP term t1 then accept

 

[email protected]> show rip neighbor                  
                  Local  Source          Destination     Send   Receive   In
Neighbor          State  Address         Address         Mode   Mode     Met 
--------          -----  -------         -----------     ----   -------  --- 
ge-0/0/0.0           Up 86.86.86.6      224.0.0.9       mcast  both       1
ge-0/0/1.0           Up 96.96.96.6      224.0.0.9       mcast  both       1

[email protected]> show rip neighbor    
                  Local  Source          Destination     Send   Receive   In
Neighbor          State  Address         Address         Mode   Mode     Met 
--------          -----  -------         -----------     ----   -------  --- 
ge-0/0/0.0           Up 97.97.97.7      224.0.0.9       mcast  both       1
ge-0/0/1.0           Up 87.87.87.7      224.0.0.9       mcast  both       1

[email protected]> show rip neighbor    
                  Local  Source          Destination     Send   Receive   In
Neighbor          State  Address         Address         Mode   Mode     Met 
--------          -----  -------         -----------     ----   -------  --- 
ge-0/0/0.0           Up 86.86.86.8      224.0.0.9       mcast  both       1
ge-0/0/1.0           Up 87.87.87.8      224.0.0.9       mcast  both       1

[email protected]> show rip neighbor    
                  Local  Source          Destination     Send   Receive   In
Neighbor          State  Address         Address         Mode   Mode     Met 
--------          -----  -------         -----------     ----   -------  --- 
ge-0/0/0.0           Up 97.97.97.9      224.0.0.9       mcast  both       1
ge-0/0/1.0           Up 96.96.96.9      224.0.0.9       mcast  both       1

 

— Routing:

Verification:

From R6--->R7 2 hops [86.86.x as primary] 
[email protected]> show route 
inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

6.6.6.0/24         *[Direct/0] 00:33:47
                    > via lo0.6
6.6.6.6/32         *[Local/0] 00:33:47
                      Local via lo0.6
7.7.7.0/24         *[RIP/100] 00:32:34, metric 3, tag 0
                      to 86.86.86.8 via ge-0/0/0.0
                    > to 96.96.96.9 via ge-0/0/1.0
86.86.86.0/24      *[Direct/0] 00:32:45
                    > via ge-0/0/0.0
86.86.86.6/32      *[Local/0] 00:32:46
                      Local via ge-0/0/0.0
87.87.87.0/24      *[RIP/100] 00:10:00, metric 2, tag 0
                    > to 86.86.86.8 via ge-0/0/0.0
96.96.96.0/24      *[Direct/0] 00:32:45
                    > via ge-0/0/1.0
96.96.96.6/32      *[Local/0] 00:32:46
                      Local via ge-0/0/1.0
97.97.97.0/24      *[RIP/100] 00:32:34, metric 2, tag 0
                    > to 96.96.96.9 via ge-0/0/1.0
224.0.0.9/32       *[RIP/100] 00:10:00, metric 1
                      MultiRecv

 

— L2 —> L1 route leaking on R5 so R5 is the prefer’d exit point to reach 192.168.1.0/24 and 2.0/24… and all other                       traffic stay the same:

Assuming R6 -->R8 is T1 line;
and want R6-->R9 as primary route assuming its 1G link
[email protected]# show |compare
[edit protocols rip group RIP neighbor ge-0/0/0.0]
+ metric-in 10;
[email protected]> show route 7.7.7.7    
inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

7.7.7.0/24         *[RIP/100] 00:45:24, metric 3, tag 0
                    > to 96.96.96.9 via ge-0/0/1.0
-- Now path has changed and this only/one path will be shown in table.
 -- R7 have two paths to reach R6.
[email protected]> show route 6.6.6.6 
inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

6.6.6.0/24         *[RIP/100] 00:51:43, metric 3, tag 0
                      to 97.97.97.9 via ge-0/0/0.0
                    > to 87.87.87.8 via ge-0/0/1.0
                    
To keep it prefer'd path using R7-> R9 -> R6, so it never get change in future.

[email protected]# show |compare 
[edit protocols rip group RIP neighbor ge-0/0/1.0]
+     metric-in 10;

[email protected]> show route 6.6.6.6    

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

6.6.6.0/24         *[RIP/100] 00:53:47, metric 3, tag 0
                    > to 97.97.97.9 via ge-0/0/0.0
 
Share on print
Print
Share on google
Google+
Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

Training individuals to equip with cutting-edge technologies & Certifications.

 

The Juniper All-Access | Reading List

Leave a reply

Your email address will not be published. Required fields are marked *

ADENTECH guides

We love to help.

Get our newsletter, join the community: